Jump to content


Photo

Taskbar visible in full screen


  • Please log in to reply
8 replies to this topic

#1 Chennek

Chennek

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 06 November 2007 - 01:01 AM

Whatever I try, the taskbar keeps being visible when I go to full screen or zoom.
  • I have selected the force hide taskbar option in the system options. This removes the taskbar, but then the vista start button (orb) is still visible.
  • I tried all the renderers that are available.
  • When using another player such as Windows Media Player, the problem does not occur.
  • I tried different file types (divx, x264 AVC , wmv, MPEG2)
  • I tried the beta 5.50
...to no avail. What is causing this?

The only way to get the taskbar away completely is by closing explorer.exe :rolleyes:
(and by going into VMR9 renderless exclusive mode - which takes forever by the way)
Note that the ZP button on the taskbar is 'pressed' when in full screen.

I hope you can help

ZP 5, windows Vista, FFDShow

#2 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8743 posts

Posted 12 November 2007 - 01:36 PM

Do you use some special multi-monitor configuration mode?
A special monitor resolution perhaps?
Perhaps an application running in the background and on the system tray that keeps updating it and pushing the taskbar to the front.

The way fullscreen works in windows is that if there is a window the covers the entire resolution of the monitor, then the taskbar detects it as fullscreen and hides itself.

#3 vermis

vermis

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 04 December 2007 - 12:48 PM

Hi, I suffer the same issue here, only ZP (any version, I tried 5.00 5.50 and 6b2) stays "under" the taskbar in fullscreen mode. Here are a few bits of info that might prove useful

- Tried toggling on/off the "Switch resolution on Fullscreen" option in the advanced options Interface-Display dialog to the same desktop values with no results
- It only happens with aero on, any other "color scheme" allows ZP to go "full fullscreeen " :D
- No special multi-monitor configuration here, just one primary display at 1360@768 32bits 60Hz
- No application running in the backgroud that updates the systray or taskbar

and as Chenneck pointed out

- It happens no matter what codec/renderer I choose
- No other application that goes fullscreen (such as games, Media Player Classic, WMP) experiments the same behavior

so I'm clueless, any help please?

PS. I would attach my exported ZP settings in case that helps, but the forum won't let me do that


edit: OK, I solved it, by "disabling the screen scale adjusting if high dpi setup is used" ( or however its translated in the English version ) in the compatibility tab under zoom player professional program properties in windows

#4 Chennek

Chennek

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 29 December 2007 - 03:36 PM

edit: OK, I solved it, by "disabling the screen scale adjusting if high dpi setup is used" ( or however its translated in the English version ) in the compatibility tab under zoom player professional program properties in windows

Great, this resolved the matter for me as well. This problem possibly occurs only when you choose a non-standard DPI setting in Windows Vista (Control Panel > Personalisation > Adjust font size (DPI)).

Selecting "Disable display scaling on high DPI settings" under the Compatibility tab of the property screen of the ZoomPlayer executable makes the task bar stay away. I wonder why the taskbar is affected when Vista scales the display on high DPI settings. Perhaps this should be looked into, or put into the FAQ.

#5 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8743 posts

Posted 02 January 2008 - 03:34 PM

Ok, this report is detailed enough for me to start tracking it down.

#6 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8743 posts

Posted 02 January 2008 - 04:19 PM

I investigated this further and can't quite seem to track it down. I've set vista to use 120 DPI and rebooted. Fullscreen still works just fine.

So here's what I need:
1. What is the exact resolution you are using?
2. What is the exact DPI you are using?
3. Is Aero on or off?
4. If you go fullscreen with no media/video loaded, does the problem occur (simply running zplayer.exe and going fullscreen)?
5. Does the problem occur if you press Alt+Enter to go fullscreen or does it only happen if you press the fullscreen button?

#7 Ayporos

Ayporos

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 18 February 2017 - 04:34 AM

I know this is a ~very~ old thread but I decided to post in it as I happened to get the same issue today seemingly out of nowhere, running on Windows 10.

1. 2560x1080
2. default
3. on
4. yes
5. either, no difference.

Additional info:
- Stay on top setting has no effect
- it worked just fine for me up until yesterday. Today I boot up my PC, do some stuff on it, and then load up zoomplayer and voila it doesn't work. So I assume ~something~ else I did today made it/windows go boo boo.
(I browsed a bit, I torrented some stuff, I watched some youtube vids, I watched some .gifs and .webms in my browser, I listened to some music via Winamp, I played some online games. I did not however update any drivers or change any settings and windows hasn't run an update according to the log)
- I did right click, properties, compatibility, run compatibility troubleshooter -> troubleshoot program -> 'the program opens but doesn't display correctly' -> it tries disabling dpi scaling and that works.
- After confirming it to be in working order I tried unchecking the 'disable display scaling on high DPI settings' setting in the windows program properties and it still worked just fine.

My gut feeling tells me it's just another case of Windows being Windows. The videogame (Rocket League via Steam) I played in fullscreen so I deem it possible somehow it didn't get closed/released properly preventing ZP from properly going fullscreen.
Maybe it's my Xbox controller? It sometimes keeps registering an input after I've put it down.


 



#8 boogafreak

boogafreak

    BoogAdmin

  • Admin
  • PipPipPipPipPip
  • 2757 posts

Posted 18 February 2017 - 12:03 PM

Hi,

 

I'm guessing one of the programs enabled dpi scaling, or so it looks.

Perhaps turning them all on again will enable you to reproduce this and get to the one program that caused it.

We'd be happy if there was a reproducible procedure..

 

Booga.



#9 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8743 posts

Posted 21 February 2017 - 05:19 PM

if some background task is taking keyboard focus it may also cause this.