Jump to content


Photo

Announcing Zoom Player v4.51 final


  • This topic is locked This topic is locked
64 replies to this topic

#1 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8341 posts

Posted 31 July 2005 - 03:32 AM

This is a bug-fix version with a few tweaks and small features.

Download Zoom Player v4.51 final.

Here is the change list from v4.51 RC1:
* New Search function on the Play History dialog.

 * New H263 Customized Media Playback video profile.

 * New AMR Customized Media Playback audio profile.

 * With the two changes above, you can now play 3GP files over
   DirectShow.  Currently, this requires the use of the Haali
   Media Splitter with the MP4 setting checked during installation
   and FFDShow with AMR enabled for the Audio Decoder and H263
   enabled for the Video Decoder.

 * New Communication API #2600 Message, allowing you to set the
   Derived Aspect ratio of the currently playing video.

 + The setting that controls whether the Increase/Decrease Rate
   function uses Fast Forward/Rewind or Fast Play/Slow Motion
   will not effect the Increase Rate/Decrease Rate functions
   and not only the user interface control.

 + The Customized Media Playback profile for MP4 files will now
   support the 3GP file format (which is basically the same file
   format).

 + Zoom Player no longer defaults to using the QuickTime Active-X
   control for the playback of 3GP files (video format used mainly
   on cell phones) as there is a DirectShow alternative which
   is much more reliable.

 + The "exSetMode" function can now be used to discretely set
   Zoom Player to Audio Mode (instead of the usual function
   which is an ON/OFF toggle).

 + Added a few safety checks so that badly formatted Communication
   API messages won't cause Zoom Player to crash.

 + Erasing a file through the navigator interfaces should no longer
   erase all the files with the same base name.

 - Color control changes should work better when the color changes
   are done while paused in Media Mode.

 - It should now be impossible for the Control Bar to appear
   if the internal screen saver is visible.

 - Manual DVD Graph mode would keep prompting you to set the
   DVD decoders if Customzied DVD Graph mode did not have
   decoder entries selected.


#2 Mastiff

Mastiff

    Guru

  • Members
  • PipPipPipPip
  • 214 posts

Posted 31 July 2005 - 09:06 AM

So now it's on to bigger, better things, like a GUI for renderless exclusive, right? :whome: That's what I've been waiting for, since I don't use all those exotic formats some users do - a regular DVD is enough compressed!

#3 groovyclam

groovyclam

    Adept

  • Members
  • PipPipPip
  • 51 posts

Posted 01 August 2005 - 11:56 AM

Ignore post: problem sorted.

#4 bitmonster

bitmonster

    Adept

  • Members
  • PipPipPip
  • 66 posts

Posted 01 August 2005 - 07:45 PM

Short question:
Doesn't ZP handle the context menu key?

Should be the default behavior I think, that an application pops up its context menu, if this key is pressed. I tried to find a suitable function in the keyboard editor, but didn't found one. I can assign the key to the context navigator, but not to the context menu.

#5 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8341 posts

Posted 02 August 2005 - 05:27 PM

bitmonster:
it's a bit complex, ZP has several conditional context-menus, which are reactive to a mouse click... so that's why it won't work like that.

Mastiff:
work has begun again on the renderless stuff, blanking first, then other stuff.

#6 bitmonster

bitmonster

    Adept

  • Members
  • PipPipPip
  • 66 posts

Posted 02 August 2005 - 05:38 PM

bitmonster:
it's a bit complex, ZP has several conditional context-menus, which are reactive to a mouse click... so that's why it won't work like that.

Well, but the menu you get if you click on the video area, is the most suitable. I would suggest to show this if the context-menu key is pressed.

#7 Mastiff

Mastiff

    Guru

  • Members
  • PipPipPipPip
  • 214 posts

Posted 02 August 2005 - 06:23 PM

Thanks, Blight! The blanking is what I need the least, but I hope you will get to the OSD/control bar after that. :)

#8 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8341 posts

Posted 02 August 2005 - 06:44 PM

bitmonster:
ok.

mastiff:
I'm thinking Blanking / Control Bar / Navigators / Pop-up OSD (in that order).

#9 Mastiff

Mastiff

    Guru

  • Members
  • PipPipPipPip
  • 214 posts

Posted 03 August 2005 - 06:37 AM

Very good! :) I can do with the contol bar, it will help a lot.

#10 Suzi

Suzi

    Adept

  • Members
  • PipPipPip
  • 102 posts

Posted 03 August 2005 - 01:36 PM

Hi Blight

When I open the color controls all color bars are displayed but only the Brightness and Saturation work properly.

So, in order to get rid of the ones that do not work/not active, I checked the Only Show the Active Bar(clear more visible space) in options.

But, ZP displays only Brightness bar and ignores the Saturation bar, which works fine.

#11 bitmonster

bitmonster

    Adept

  • Members
  • PipPipPip
  • 66 posts

Posted 03 August 2005 - 01:42 PM

Hi Blight

When I open the color controls all color bars are displayed but only the Brightness and Saturation work properly.

So, in order to get rid of the ones that do not work/not active, I checked the Only Show the Active Bar(clear more visible space) in options. 

But, ZP displays only Brightness bar and ignores the Saturation bar, which works fine.

This option has another meaning. It only shows the currently selected bar. So if you press the down-key while this single bar shows up, you should see, that the next bar comes into view.

But this wont help to hide bars, that are not active.

#12 Suzi

Suzi

    Adept

  • Members
  • PipPipPip
  • 102 posts

Posted 05 August 2005 - 12:38 AM

Thanks, bitmonster

I understood, the option meant that it will hide the non active and show only the active bars.

#13 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8341 posts

Posted 05 August 2005 - 06:07 AM

I changed the word "active" to "selected" just to make it clearer in the future.

#14 yesgrey3

yesgrey3

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 08 August 2005 - 11:46 AM

Hi Blight,

I have posted today a thread in avsforum HTPC with title "How I solve my stuttering problems...".

I would like to know if you can give it a look. I don't know if it could be a ZoomPlayer bug...

Thanks.

yesgrey3

#15 coch

coch

    Greenhorn

  • Members
  • PipPip
  • 18 posts

Posted 11 August 2005 - 04:24 AM

Hi Blight.

The new version is great. I got two issues though and I hope someone can help me out or maybe it is a bug. Did not find any post about that.

1) When assiciating zoom player with movie files (avi, mpg and wmv) and setting Zoom player to save settings in a local file rather than the registry, double clicking a movie file fails to load the file if another movie file is already loaded. For instance, if I open a movie in ZP and then double click another movie in a folder while the first one is still loaded, the second one will not load. This does not occur if ZP is set to store settings in the registry.

2) The setting to remember last media position setting is not saving. I check the box, and next time I open ZP it is unchecked.


edit: just found that this was actually reported here http://forum.inmatrix.com/index.php?showto...mber+last+media

and I am experiencing the same thing.

#16 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8341 posts

Posted 11 August 2005 - 10:11 PM

coch:
1. A local-setting file won't auto-associate file extensions on a new system if you move it. But i'll check if the problem exists just by switching the setting, although I seriously doubt it (due to how that setting works).
2. I really hope you're not using a cracked version, cause that wouldn't be nice... If you're not, re-download the installer from the inmatrix home page and re-install and also run a virus-check as this is an indication of ZP's exe being changed.

#17 coch

coch

    Greenhorn

  • Members
  • PipPip
  • 18 posts

Posted 11 August 2005 - 10:47 PM

Thanks for the reply Blight

1. Yes, does also happen when just switching it and restarting ZP.

2. No cracked version here, but ran a scan annd I did have a virus, albeit it was not in Zoom Player. Removing virus and reinstalling ZP seemed to fix the problem.

#18 bLight

bLight

    Lead Developer

  • Admin
  • PipPipPipPipPip
  • 8341 posts

Posted 17 August 2005 - 09:49 PM

coch:
regarding the run thing... are you running multiple instances of ZP, from different locations? The microsoft file association interface requires a fixed location for association to work.

#19 coch

coch

    Greenhorn

  • Members
  • PipPip
  • 18 posts

Posted 18 August 2005 - 01:29 AM

Hi, no only one instance, and ZP is only installed in a single location, the default installation folder. You cannot reproduce what I am experiencing?

#20 louismo

louismo

    Greenhorn

  • Members
  • PipPip
  • 43 posts

Posted 25 August 2005 - 04:37 AM

I've found something that will cause ZP to hang.

While playing a mpeg2 clip, press the following user-defined key sequences:

AddKey(None,36,fnNextFrame)
AddKey(None,36,fnNextFrame)
exAddKey(None,36,exSetPlayRate,3000)

or

AddKey(None,36,fnPlay)
AddKey(None,36,fnNextFrame)
exAddKey(None,36,exSetPlayRate,3000)

or

AddKey(None,36,fnPause)
AddKey(None,36,fnNextFrame)
exAddKey(None,36,exSetPlayRate,3000)

Thanks